ANTAGONIST
False Prophet

To play this game you must have JDK 1.2 installed on your PC. You can download it for free at:
http://java.sun.com/getjava/download.html

The plugin is about 5 Mb, it is to enable your browser to have latest JDK support. Most browsers have JDK 1.1 installed by default, but JDK 1.2 is minimum requirement.

Keypad, PgUp/PgDown/Home/End to move character
Left mouse click to move character (path finding)
TAB key or right mouse click to open Command Menu

Click HERE to continue.

The game will be updated periodically, as I am still developing on it. Any suggestions or comments for game improvement or question, please mail to lexzeus@hotmail.com, thanks!